Karachee (karachee) wrote,
Karachee
karachee

конкурс 1с извращенцев

Как найти третий символ в строке ...
... штатными средствами 1С77 ..., не используя методов Лев(), Прав(), Сред(), Формат() и Шаблон() ...


Функция Рекурсия(ИсходнаяСтрока,Символ,номер)
ТотСамый="Охренел что-ли меньшепервый символ искать !!!";
Для Шаг=1 по 255 Цикл
Если Найти(ИсходнаяСтрока, Символ+Симв(Шаг))=1 тогда
Символ=Символ+Симв(Шаг);
номер=номер-1;
Если номер=0 тогда
возврат(Симв(Шаг));
КонецЕсли;
ТотСамый=Рекурсия(ИсходнаяСтрока,Символ,номер);
КонецЕсли;
Если номер<1 тогда
возврат(ТотСамый);
КонецЕсли;
КонецЦикла;

КонецФункции


Процедура Сформировать()
ТотСимвол=Рекурсия(ИсходнаяСтрока,"",3);
Сообщить(ТотСимвол);

КонецПроцедуры



Хотя конечно это компиляция чужой идеи, надо придумать что-то ещё более свое.
Начальная ветка здесь, продожение где-то на mista.ru
Subscribe

  • фотолюбительское

    Картинку свистнул на Пикабу. Замечательная иллюстрация разницы между модельной и не модельной внешностью. При съемке модели любой ракурс, любая…

  • (no subject)

    Написал в нескольких ветках комментариев по Дворцам/Путиным, что сумма в 100 миллиардов меня совершенно не возбуждает. Когда с одной стороны "Путин -…

  • мои комментарии

    Если человек сидит на жопе - ему неплохо объективно. На горячей сковороде сидеть не будет никто, горящая жопа не позволит. Если сидит, значит ещё не…

  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments